Start a conversation

Minimum Mobile Requirements

Currently, our IMU-Step mobile app is only available for iOS devices.


To run IMU Step, your iPad or iPhone must be equipped with Bluetooth 4.2 or better and be updated to iOS 12 or above. The list below outlines compatible devices:

Minimum
iPhone:  iPhone 5s or newer
iPad Mini: 5th generation or newer
iPad: 5th generation or newer
iPad Pro: compatible


Recommended
iPhone XS and XS Max
iPhone XR
iPad Mini (5th Gen)
iPad Air (2020, 4th Gen)

iPad Pro 2021 (5th Gen)

iPhone 11, iPhone 11 Pro, 11 Pro Max, and 12

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. James Grant

  2. Posted
  3. Updated

Comments